本站文章部分原创,其他互联网采集,如有侵权,请联系管理员删除。邮箱:admin@yunwei.org.cn

华为三层交换机(S3700/S5700)常用命令

网络知识 fento 173℃ 0评论

用户视图:

save    // 配置完交换机后保存当前配置的命令
system-view    // 进入系统视图的命令
clock  timezone  BJ  add|minus 8   // 设置时区
clock  datetime  16:36:00 2016-07-01    //设置交换机的时间

系统视图:

display current-configuration  // 显示当前配置
user-interface maximum-vty 15  //配置vty最大连接数
user-interface vty 0 14     //进入vty用户界面视图
user privilege level 2      //设置vty登入的用户等级为2(配置用户级别)
authentication-mode aaa  //设置vty登入时的验证模式为用户名和密码验证

aaa  //进入AAA视图
local-user admin password cipher admin@123  //设置aaa登入的用户名和密码
local-user admin service-type telnet  //设置admin用户远程登入时的协议

user-interface console 0     //进入第0个console口的用户界面
authentication-mode passwd   //配置从console口登入交换机的认证模式为密码认证
set authentication password cipher admin@123  //配置从console口登入交换机的密码

vlan 10 //创建一个VLAN

1.在用户视图下用dir查看下WEB文件的名称!记下来,比如文件名是:XXX..web.zip

dir

找到s5700si-v200r003c00.001.web.7z 如此类似的文件一般包含"web"关键字

2.进入系统视图模式,加载web文件资源,并启用http服务。
 system-view
[S5700]http server load s5700si-v200r003c00.001.web.7z
[S5700]http secure-server enable
[S5700]http server enable

AAA认证及账号密码配置

[S5700]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode aaa  
user-interface vty 0 4
authentication-mode aaa 
----------------------------------------------------------------------
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher 123456
 local-user admin privilege level 15
 local-user admin service-type telnet terminal http web 
----------------------------------------------------------------------

vlan 10 //创建一个VLAN

interface meth 0/0/1   //进入交换机的第一个管理网口
ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码

interface gigabitethernet 0/0/1 //进入第一个业务网口
port link-type access  //设置第1个网口位access模式
port default vlan 10   //设置此网口的VLAN号为10

interface gigabitethnet 0/0/2 //进入第2个业务网口
port link-type trunk   //设置第二个网口位trunk模式
port trunk allow-pass vlan 10 20 30  //设置此端口可以通过的VLAN号
// port trunk allow-pass vlan all  表示可以通过所有的带VLAN的帧
Interface gigabitethnet 0/0/3  //进入第3个业务网口
Port link-type hybrid     //设置此端口为hybrid模式,每个端口默认就是hybrid模式
Port hybrid pvid vlan 10   //设置pvid为10
Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40
Port hybrid untagged vlan 50 60 //设置untagged列表为50,60

Display port vlan  //显示当前各端口的VLAN情况

清除某个端口的配置

Interface gigabitethernet 0/0/2
Clear configuration this
Undo shutdown

Interface gigabitethernet 0/0/3
Undo port default vlan  //access 模式的端口
Undo port link-type 
Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
Undo port hybrid untagged vlan vlanid 
Undo port hybrid tagged vlan vlanid 
Undo port trunk pvid vlan  //trunk 模式的端口
Undo port trunk allow-pass vlan vlanid 
Undo port link-type

清除某个端口的配置

恢复出厂设置s5700SI
在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作
reset saved-configuration
Y
Reboot
N
Y

三层交换机接路由器LAN口

Vlan 60 70
Interface vlanif 60
ip address 192.168.60.1 24  //VLAN60的管理地址
interface vlanif 70
ip address 192.168.1.238 24  //VLAN70的管理地址
interface gigabitethernet 0/0/3
port link-type access
port default vlan 60
interface gigabitethernet 0/0/4
port link-type access
port default vlan 70
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1  
在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址

二层交换机与三层连接,但是无法联通防火墙

假如 拓扑是  USG6300-S5700-S2700 架构

现象:S2700下面的VLAN 无法访问到三层的主管理VLAN
解决:在S5700加一条回程路由 指向S2700的管理地址

转载请注明:FenTo的充电站 » 华为三层交换机(S3700/S5700)常用命令

喜欢 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址